Compilar Aegisub 3.0.2 en Linux Mint 14 (Ubuntu 12.10)

Bueno, ayer tras un soplo de Gunscold me hice con la nueva versión de Aegisub. La 3.0

Para poder echarle un vistazo, no queda más remedio que compilar la versión para nuestro linux, ya que no estará en los repositorios o en PPA’s hasta dentro de algún tiempo.

Para los inquietos, publico el procedimiento que seguí para tenerlo funcionando en Mint 14 (Ubuntu 12.10).

En primer lugar y como siempre abrimos un terminal y nos hacemos con las dependencias para poder compilar. Estas son:

 sudo apt-get install autoconf automake libtool intltool imagemagick yasm subversion gcc g++ pkg-config libstdc++6-4.5-dev libfontconfig1-dev libfreetype6-dev libgl1-mesa-dev libglu1-mesa-dev libglib2.0-dev liblua5.1-0-dev libhunspell-dev libopenal-dev libasound2-dev libpulse-dev wx-common libwxgtk2.8-dev libass-dev libgettext-ocaml-dev libavformat-dev libswscale-dev checkinstall libffms2-dev libgtk2.0-dev

No he incluido el soporte de portaudio ya que me daba problemas y no quería compilarlo, pero no es necesario ya que podemos conseguir el soporte mediante alsa o oss.

Al ser un programa bastante moderno, necesita de las wxWidgets en su versión 2.9.3 o superior y la que viene con Precise es la 2.8, así que hala, a compilar:

nos vamos a nuestro directorio de trabajo y conseguimos las fuentes:

cd ~

wget http://sourceforge.net/projects/wxwindows/files/latest/wxWidgets-2.9.4.tar.bz2

tar -xjvf wxWidgets-2.9.4.tar.bz2
cd ~/wxWidgets-2.9.4

y ahora lo de siempre:

./configure

make

sudo make install 

Y como no me reconocía los directorios de las librerías de wx tuve que actualizarlos en el sistema:

sudo ldconfig

y ahora vamos a por el aegisub:

cd ~

wget http://ftp.aegisub.org/pub/releases/aegisub-3.0.2.tar.xz
tar -Jxf aegisub-3.0.2.tar.xz

cd aegisub/aegisub

./configure
make
sudo make install

y listo, funcionando.

Esta entrada fue publicada en Artículos, Guías. Guarda el enlace permanente.

8 respuestas a Compilar Aegisub 3.0.2 en Linux Mint 14 (Ubuntu 12.10)

  1. etto… hola, segui el tutorial, pero me aparecio un error:

    checking for ICU_UC… no
    configure: error: Package requirements (icu-uc >= 4.8.1.1) were not met:

    No package ‘icu-uc’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables ICU_UC_CFLAGS
    and ICU_UC_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    como sea, me encontre este paquete .deb : http://ftp.aegisub.org/pub/releases/aegisub_3.0.4-1_i386.deb
    lo instale y me funciono perfectamente, aunke tabien puede que las dependencias ke instale antes lo hayan echo funcionar, no lo se, pero funciona 😀

  2. Oye yo segui esto paso por paso he iba bien pero a la hora de querer instalar el aegisub, no me dejaba hacerlo, me salio que no existia el archivo (404 not found) de casualidad no sabes que paso?

  3. SBJSB dijo:

    Hola y gracias por el tuto =D, no te paso que en la versión 2,1,9 se te serraba de un momento a otro????? y una duda hace poco note que salio la versión 3,0,1 pero no la pude instalar jeje ahora con tu tuto logre avanzar mas al tratar de instalar la nueva versión 3,0,2 pero ala hora de poner sudo make install me tira error y no se que sera, también debo decir que todavía tengo instalado la versión 2,1,9 tengo que desinstalarla???? no lo e echo todavía por que no se desinstalarla jeje

  4. Al_eXs dijo:

    Espero que este si funcione y se pueda compilar, ya que el anterior no pude compilarlo el par de veces que intenté.

    Y para instalar paquetes compilados yo uso el Checkinstall, lo recomiendo, es una utilería muy buena para poder desinstalar y reinstalar paquetes compilados por uno mismo de manera fácil y sencilla ya que crea un paquete .deb o .rpm dependiendo de la distro.

    Ahora que reinstale lo pruebo, gracias por dejar las dependencias, que creo que me faltaba alguna.

    Saludos.

  5. Habrá que probarlo, tengo años usando el gnome subtitles y que mejor forma de modernizarse con aegisub. Gracias por informar .

    Salu2

Deja un comentario